Yes, it works fine with 4.0.