Woud this plugin br compatible with version 4.0?