I’m using the plugin with 3.8 (and trunk), and not having any problems; do you have any other plugins running that might interfere/interact with authentication which are perhaps causing a conflict of some sort?