webpad Requirements

Client Requirements (to actually use webpad)

webpad currently supports the following browsers/platforms. It may support others, but due to the complexity of some of the JavaScript used (specifically for the HTML tools), it may not perform entirely as expected. All browsers will need JavaScript, cookies and CSS enabled, and you should allow popups for the domain you have webpad installed on in any popup blocking tools you have.

  • Windows 2000/XP
    • Internet Explorer 6.0+
    • Mozilla Firefox 1.0+
  • Macintosh OS X
    • Mozilla Firefox 1.0+
    • Mozilla Camino 0.8+
  • Screen Resolution: 1024 x 768+ (there are lots of tools in the toolbar!)

Support for other browsers (esp. Safari) and platforms (hopefully Linux) is hopefully coming in future versions – if you’d like to help then please get in touch with me to discuss testing etc.

NOTE: Safari on OS X is not currently supported – it has some problems with the HTML tools in webpad that cause them to function incorrectly.

Server Requirements (on your webserver)

webpad is pretty light on your server, and doesn’t require too many additional modules, but there are some that you will need. These tend to be very common, so if you don’t know, then give it a try and you probably have them already!

  • Apache (tested on 1.34 only) or IIS
  • PHP4 (most recent versions will be fine), running either in CGI mode, or as a server module.
  • cURL (for blogging, and opening the source of webpages).
  • expat (xml functions, again for blogging. These should be enabled by default, so unless they’ve been disabled, you should be fine).
  • FTP functions (some web hosts disable these functions for security reasons, but generally you should be fine)

Comments